Issues Running Tabs3 and PracticeMaster Software under Windows 2000/XP

Last reviewed: 10/06/2010
Article ID: R10705

The information in this article applies to:

SUMMARY

Tabs3 and PracticeMaster Version 15 software will run under Windows 2000 and Windows XP; however, there are a few minor issues that have been encountered. This article discusses the following issues:

Version 16

Beginning with Version 16, Tabs3 and PracticeMaster software do not support Windows 2000. Attempting to install Tabs3 or PracticeMaster on Windows 2000 will display an error, as noted in KB Article R11382, "Unsupported Operating System Errors".

Overdue tasks do not use red text when using the "Silver" color scheme in Windows XP

Note: This issue only applies to Version 12 and earlier.  This issue does not apply to Version 14 or greater.

It has been discovered that when using the "Silver" color scheme in Windows XP, overdue calendar tasks do not use red text when displayed in the Task List. This issue was fixed in January 2006. If you are using Version 12 and are on maintenance, download the most current version of the software from our Web site. You can access our download site while using PracticeMaster by selecting Help | Internet Resources | Software Update. Or, you can use the following instructions to select a different color scheme:

  1. Click Start, and then click Control Panel (or, if you use the "classic" Start Menu, point to Settings and then click Control Panel).
  2. Double-click Display, and then click the Appearance tab.
  3. Click the drop-down button in the Color Scheme field and select a color scheme other than "Silver".
  4. Click OK to apply your changes and close the Display window.

Calendar Shading Not Visible in PracticeMaster

This issue may occur when viewing a Daily or Weekly Calendar in PracticeMaster. In general, non-working hours appear gray when viewing a PracticeMaster Daily or Weekly Calendar. When using a Windows theme in which the background color is white, it is not possible to see the shading in the calendar. To make the shading visible, you will need to change the color settings within Windows, or you can select the Windows Classic theme.

To change the background color setting in Windows XP

  1. Click Start, and then click Control Panel.
  2. Double-click Display, and then click the Appearance tab.
  3. Click the Advanced button.
  4. Select the 3D Objects item.
  5. Choose a darker color than the current setting.
  6. Click OK and then click OK to apply the setting.

To select the Windows Classic theme

  1. Click Start, and then click Control Panel.
  2. Double-click Display.
  3. Select Windows Classic.
  4. Click OK to apply your changes and close the Display window.

Installing Tabs3 and PracticeMaster Software

It is possible to receive the following error when installing Tabs3 and PracticeMaster software on a Windows 2000 or Windows XP workstation:

Error Extracting Support files - Access Denied

Cause

This is caused by insufficient permissions on the workstation to which you are installing.

Resolution

InstallShield is the third party software program that we use for our installation programs. You will need to have administrative permissions to run the InstallShield Professional 6.x setup program under this platform, in order to install the required DLL files to the appropriate Windows folders. Make sure that you have the correct permissions. Once the correct permissions have been granted, reinstall the Tabs3 and PracticeMaster software on the workstation.

Note: If you continue to experience the error when trying to install, refer to KB Article R10812, "Troubleshooting Tabs3 and PracticeMaster CD Installations."

Starting PracticeMaster

Note: This issue only applies to Version 12 and earlier.  This issue does not apply to Version 14 or greater.

Upon opening PracticeMaster, the program attempts to write to the registry. When it cannot write to the registry, the following error message can be displayed:

Failed to update system registry, you must use regedit.

Cause

Windows 2000/XP has the ability to limit the rights of users who log into an individual workstation.  If a user does not have full rights to edit the registry, this error is displayed each time PracticeMaster is started.

Resolution

Note: The software was changed in September 2005 so that this message does not appear if a user does not have rights to edit the registry. Note, however, that Word Document Assembly will not work correctly on a given workstation until an administrator or power user runs PracticeMaster on that workstation. If you are using Version 12 and are on maintenance, download the most current version of the software from our Web site. You can access our download site while using PracticeMaster by selecting Help | Internet Resources | Software Update.

Alternately, you an assign the user POWER USER rights or give the user full rights to edit the registry on his or her workstation. Once adequate rights have been granted, the message will no longer occur when PracticeMaster is started.

Scroll Bars are missing

Under certain conditions, scroll bars may not appear in various fields such as client notes, cost description, tcode description, text macro description, payment description, client funds description, statement notes, and lines of text to be printed at the end of each billing statement. This is a bug in Microsoft's code (not Software Technology's code).

Example

When you are entering a cost entry and the text that is entered is more than can be viewed in the visible area, the scroll bars will not be displayed.  However, once the entry is saved, the scroll bars will be available for the cost record and any other cost record that is added.  If you exit the cost data entry program and reload it, once again you will have to perform a save before the scroll bars will be visible.

Solution

Use the PgDn key, PgUp key, and arrow keys to move through the field.

1120 and 1310 Fatal Errors a result of SMB Signing on Windows XP

Users running Windows XP connecting to a Windows 2000 server may receive errors such as:

Cause

Client computers that are running Windows XP Service Pack 1 (SP1) that are configured to require Server Message Block (SMB) signing may drop SMB signing and may have problems communicating over your network.

Solution

Read the following Microsoft KB Articles and either disable SMB Signing or obtain the Microsoft fix for this issue.

References


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